{"cve":"CVE-2024-23114","nvd":{"published":"2024-02-20T15:15:10.333","modified":"2026-06-17T07:12:03.673","status":"Analyzed","description":"Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.\n\nUsers are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://camel.apache.org/security/CVE-2024-23114.html","https://camel.apache.org/security/CVE-2024-23114.html"],"products":["apache:camel"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-23114","score":0.01273,"percentile":0.6989,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m43p-55rf-8c2j","url":"https://osv.dev/vulnerability/GHSA-m43p-55rf-8c2j","summary":"Deserialization of Untrusted Data in Apache Camel CassandraQL","modified":"2024-11-29T05:38:25.323215Z","packages":[{"ecosystem":"Maven","name":"org.apache.camel:camel-cassandraql","purl":"pkg:maven/org.apache.camel/camel-cassandraql","ranges":[">=3.0.0 <3.21.4"],"fixed":["3.21.4"]},{"ecosystem":"Maven","name":"org.apache.camel:camel-cassandraql","purl":"pkg:maven/org.apache.camel/camel-cassandraql","ranges":[">=3.22.0 <3.22.1"],"fixed":["3.22.1"]},{"ecosystem":"Maven","name":"org.apache.camel:camel-cassandraql","purl":"pkg:maven/org.apache.camel/camel-cassandraql","ranges":[">=4.0.0 <4.0.4"],"fixed":["4.0.4"]},{"ecosystem":"Maven","name":"org.apache.camel:camel-cassandraql","purl":"pkg:maven/org.apache.camel/camel-cassandraql","ranges":[">=4.1.0 <4.4.0"],"fixed":["4.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}