{"cve":"CVE-2024-22419","nvd":{"published":"2024-01-18T19:15:10.550","modified":"2026-06-17T07:11:22.500","status":"Modified","description":"Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine. The `concat` built-in can write over the bounds of the memory buffer that was allocated for it and thus overwrite existing valid data. The root cause is that the `build_IR` for `concat` doesn't properly adhere to the API of copy functions (for `>=0.3.2` the `copy_bytes` function). A contract search was performed and no vulnerable contracts were found in production. The buffer overflow can result in the change of semantics of the contract. The overflow is length-dependent and thus it might go unnoticed during contract testing. However, certainly not all usages of concat will result in overwritten valid data as we require it to be in an internal function and close to the return statement where other memory allocations don't occur. This issue has been addressed in 0.4.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-787","CWE-120"],"references":["https://github.com/vyperlang/vyper/commit/55e18f6d128b2da8986adbbcccf1cd59a4b9ad6f","https://github.com/vyperlang/vyper/issues/3737","https://github.com/vyperlang/vyper/security/advisories/GHSA-2q8v-3gqq-4f8p","https://github.com/vyperlang/vyper/commit/55e18f6d128b2da8986adbbcccf1cd59a4b9ad6f","https://github.com/vyperlang/vyper/issues/3737"],"products":["vyperlang:vyper"],"source":"nvd","synced_at":"2026-10-19T21:44:57.175229480+00:00"},"epss":{"cve":"CVE-2024-22419","score":0.0077,"percentile":0.55657,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2q8v-3gqq-4f8p","url":"https://osv.dev/vulnerability/GHSA-2q8v-3gqq-4f8p","summary":"concat built-in can corrupt memory in vyper","modified":"2026-09-10T03:50:04.648916948Z","packages":[{"ecosystem":"PyPI","name":"vyper","purl":"pkg:pypi/vyper","ranges":[">=0.3.0 <0.4.0"],"fixed":["0.4.0"]}]},{"id":"PYSEC-2024-103","url":"https://osv.dev/vulnerability/PYSEC-2024-103","summary":"","modified":"2024-10-09T23:44:14.237516Z","packages":[{"ecosystem":"PyPI","name":"vyper","purl":"pkg:pypi/vyper","ranges":["<0.4.0b1"],"fixed":["0.4.0b1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}