{"cve":"CVE-2024-22415","nvd":{"published":"2024-01-18T21:15:09.087","modified":"2026-06-17T07:11:21.953","status":"Modified","description":"jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-22","CWE-23","CWE-284","CWE-306"],"references":["https://github.com/jupyter-lsp/jupyterlab-lsp/commit/4ad12f204ad0b85580fc32137c647baaff044e95","https://github.com/jupyter-lsp/jupyterlab-lsp/security/advisories/GHSA-4qhp-652w-c22x","https://github.com/jupyter-lsp/jupyterlab-lsp/commit/4ad12f204ad0b85580fc32137c647baaff044e95","https://github.com/jupyter-lsp/jupyterlab-lsp/security/advisories/GHSA-4qhp-652w-c22x"],"products":["jupyter:language_server_protocol_integration"],"source":"nvd","synced_at":"2026-10-19T21:44:57.175229480+00:00"},"epss":{"cve":"CVE-2024-22415","score":0.00491,"percentile":0.42235,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-4qhp-652w-c22x","url":"https://osv.dev/vulnerability/GHSA-4qhp-652w-c22x","summary":"Unsecured endpoints in the jupyter-lsp server extension","modified":"2026-09-10T03:50:04.789845699Z","packages":[{"ecosystem":"PyPI","name":"jupyter-lsp","purl":"pkg:pypi/jupyter-lsp","ranges":["<2.2.2"],"fixed":["2.2.2"]}]},{"id":"PYSEC-2026-1478","url":"https://osv.dev/vulnerability/PYSEC-2026-1478","summary":"Unsecured endpoints in the jupyter-lsp server extension","modified":"2026-07-07T17:46:13.871473697Z","packages":[{"ecosystem":"PyPI","name":"jupyter-lsp","purl":"pkg:pypi/jupyter-lsp","ranges":["<2.2.2"],"fixed":["2.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}