{"cve":"CVE-2024-21910","nvd":{"published":"2024-01-03T16:15:09.090","modified":"2026-07-14T23:17:14.457","status":"Modified","description":"TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/advisories/GHSA-r8hm-w5f7-wj39","https://github.com/jazzband/django-tinymce/issues/366","https://github.com/jazzband/django-tinymce/releases/tag/3.4.0","https://github.com/tinymce/tinymce/security/advisories/GHSA-r8hm-w5f7-wj39","https://pypi.org/project/django-tinymce/3.4.0/"],"products":["tiny:tinymce"],"source":"nvd","synced_at":"2026-10-19T21:43:38.875533635+00:00"},"epss":{"cve":"CVE-2024-21910","score":0.00956,"percentile":0.61432,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r8hm-w5f7-wj39","url":"https://osv.dev/vulnerability/GHSA-r8hm-w5f7-wj39","summary":"Cross-site scripting vulnerability in TinyMCE plugins","modified":"2026-07-08T06:53:11.097496175Z","packages":[{"ecosystem":"npm","name":"tinymce","purl":"pkg:npm/tinymce","ranges":["<5.10.0"],"fixed":["5.10.0"]},{"ecosystem":"Packagist","name":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","ranges":["<5.10.0"],"fixed":["5.10.0"]},{"ecosystem":"NuGet","name":"TinyMCE","purl":"pkg:nuget/TinyMCE","ranges":["<5.10.0"],"fixed":["5.10.0"]},{"ecosystem":"PyPI","name":"django-tinymce","purl":"pkg:pypi/django-tinymce","ranges":["<3.4.0"],"fixed":["3.4.0"]}]},{"id":"PYSEC-2026-632","url":"https://osv.dev/vulnerability/PYSEC-2026-632","summary":"Cross-site scripting vulnerability in TinyMCE plugins","modified":"2026-07-06T08:00:11.733031007Z","packages":[{"ecosystem":"PyPI","name":"django-tinymce","purl":"pkg:pypi/django-tinymce","ranges":["<3.4.0"],"fixed":["3.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}