{"cve":"CVE-2024-21539","nvd":{"published":"2024-11-19T05:15:16.453","modified":"2026-08-03T16:16:26.043","status":"Deferred","description":"Versions of the package @eslint/plugin-kit before 0.2.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by exploiting this vulnerability.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P","score":7.7},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-1333","CWE-770"],"references":["https://github.com/eslint/rewrite/commit/071be842f0bd58de4863cdf2ab86d60f49912abf","https://security.snyk.io/vuln/SNYK-JS-ESLINTPLUGINKIT-8340627"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:57:34.731061660+00:00"},"epss":{"cve":"CVE-2024-21539","score":0.00507,"percentile":0.43279,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-7q7g-4xm8-89cq","url":"https://osv.dev/vulnerability/GHSA-7q7g-4xm8-89cq","summary":"Regular Expression Denial of Service (ReDoS) in @eslint/plugin-kit","modified":"2026-09-10T03:50:20.453343541Z","packages":[{"ecosystem":"npm","name":"@eslint/plugin-kit","purl":"pkg:npm/%40eslint/plugin-kit","ranges":["<0.2.3"],"fixed":["0.2.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}