{"cve":"CVE-2024-21535","nvd":{"published":"2024-10-15T05:15:11.530","modified":"2026-06-17T07:09:41.770","status":"Analyzed","description":"Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/quantizor/markdown-to-jsx/commit/8eb74da825c0d8d2e9508d73c672bcae36ba555a","https://security.snyk.io/vuln/SNYK-JS-MARKDOWNTOJSX-6258886"],"products":["quantizor:markdown-to-jsx"],"source":"nvd","synced_at":"2026-10-19T21:55:31.737901711+00:00"},"epss":{"cve":"CVE-2024-21535","score":0.00518,"percentile":0.4406,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4wx3-54gh-9fr9","url":"https://osv.dev/vulnerability/GHSA-4wx3-54gh-9fr9","summary":"Cross site scripting in markdown-to-jsx","modified":"2024-10-15T18:12:20.318536Z","packages":[{"ecosystem":"npm","name":"markdown-to-jsx","purl":"pkg:npm/markdown-to-jsx","ranges":["<7.4.0"],"fixed":["7.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}