{"cve":"CVE-2024-1735","nvd":{"published":"2024-02-26T16:27:53.123","modified":"2026-06-17T07:04:53.747","status":"Analyzed","description":"A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1},"cwes":["CWE-287"],"references":["https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54","https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54"],"products":["linecorp:armeria"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-1735","score":0.00834,"percentile":0.57678,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4m6j-23p2-8c54","url":"https://osv.dev/vulnerability/GHSA-4m6j-23p2-8c54","summary":"Armeria SAML authentication bypass due to missing validation on unsigned SAML messages","modified":"2026-07-08T06:52:59.872809991Z","packages":[{"ecosystem":"Maven","name":"com.linecorp.armeria:armeria-saml","purl":"pkg:maven/com.linecorp.armeria/armeria-saml","ranges":["<1.27.2"],"fixed":["1.27.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}