{"cve":"CVE-2024-1597","nvd":{"published":"2024-02-19T13:15:07.740","modified":"2026-06-17T07:04:36.577","status":"Modified","description":"pgjdbc, the PostgreSQL JDBC Driver, allows attacker to inject SQL if using PreferQueryMode=SIMPLE. Note this is not the default. In the default mode there is no vulnerability. A placeholder for a numeric value must be immediately preceded by a minus. There must be a second placeholder for a string value after the first placeholder; both must be on the same line. By constructing a matching string payload, the attacker can inject SQL to alter the query,bypassing the protections that parameterized queries bring against SQL Injection attacks. Versions before 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, and 42.2.28 are affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-89"],"references":["http://www.openwall.com/lists/oss-security/2024/04/02/6","https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-24rp-q3w6-vc56","https://lists.debian.org/debian-lts-announce/2024/05/msg00007.html","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TZQTSMESZD2RJ5XBPSXH3TIQVUW5DIUU/","https://security.netapp.com/advisory/ntap-20240419-0008/"],"products":["fedoraproject:fedora","postgresql:postgresql_jdbc_driver"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-1597","score":0.0481,"percentile":0.91963,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-24rp-q3w6-vc56","url":"https://osv.dev/vulnerability/GHSA-24rp-q3w6-vc56","summary":"org.postgresql:postgresql vulnerable to SQL Injection via line comment generation","modified":"2026-09-10T03:50:05.363063642Z","packages":[{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":["<42.2.28"],"fixed":["42.2.28"]},{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":[">=42.3.0 <42.3.9"],"fixed":["42.3.9"]},{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":[">=42.4.0 <42.4.4"],"fixed":["42.4.4"]},{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":[">=42.5.0 <42.5.5"],"fixed":["42.5.5"]},{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":[">=42.6.0 <42.6.1"],"fixed":["42.6.1"]},{"ecosystem":"Maven","name":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","ranges":[">=42.7.0 <42.7.2"],"fixed":["42.7.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}