{"cve":"CVE-2023-5214","nvd":{"published":"2023-10-06T18:15:12.453","modified":"2026-06-17T06:48:06.197","status":"Modified","description":"In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-269"],"references":["https://www.puppet.com/security/cve/cve-2023-5214-privilege-escalation-puppet-bolt","https://www.puppet.com/security/cve/cve-2023-5214-privilege-escalation-puppet-bolt"],"products":["puppet:bolt"],"source":"nvd","synced_at":"2026-10-19T21:39:34.467980132+00:00"},"epss":{"cve":"CVE-2023-5214","score":0.00447,"percentile":0.38938,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-289m-2964-f8q5","url":"https://osv.dev/vulnerability/GHSA-289m-2964-f8q5","summary":"Puppet Bolt privilege escalation vulnerability","modified":"2024-02-16T08:13:05.594543Z","packages":[{"ecosystem":"RubyGems","name":"bolt","purl":"pkg:gem/bolt","ranges":["<3.27.4"],"fixed":["3.27.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}