{"cve":"CVE-2023-51437","nvd":{"published":"2024-02-07T10:15:08.137","modified":"2026-06-17T06:40:57.363","status":"Modified","description":"Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification.\nUsers are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file.\n\nAny component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker.\n\n2.11 Pulsar users should upgrade to at least 2.11.3.\n3.0 Pulsar users should upgrade to at least 3.0.2.\n3.1 Pulsar users should upgrade to at least 3.1.1.\nAny users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions.\n\nFor additional details on this attack vector, please refer to  https://codahale.com/a-lesson-in-timing-attacks/ .","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","score":7.4},"cwes":["CWE-203"],"references":["https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5","https://www.openwall.com/lists/oss-security/2024/02/07/1","https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5","https://www.openwall.com/lists/oss-security/2024/02/07/1"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:44:57.175229480+00:00"},"epss":{"cve":"CVE-2023-51437","score":0.00763,"percentile":0.55386,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-c57v-4vg5-cm2x","url":"https://osv.dev/vulnerability/GHSA-c57v-4vg5-cm2x","summary":"Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability","modified":"2024-07-22T09:45:44.129610Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker-auth-sasl","purl":"pkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl","ranges":["<2.11.3"],"fixed":["2.11.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker-auth-sasl","purl":"pkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl","ranges":[">=3.0.0 <3.0.2"],"fixed":["3.0.2"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker-auth-sasl","purl":"pkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl","ranges":[">=3.1.0 <3.1.1"],"fixed":["3.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}