{"cve":"CVE-2023-4771","nvd":{"published":"2023-11-16T14:15:28.913","modified":"2026-06-17T06:38:33.920","status":"Modified","description":"A Cross-Site scripting vulnerability has been found in CKSource CKEditor affecting versions 4.15.1 and earlier. An attacker could send malicious javascript code through the /ckeditor/samples/old/ajax.html file and retrieve an authorized user's information.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://www.incibe.es/en/incibe-cert/notices/aviso/cross-site-scripting-vulnerability-cksource-ckeditor","https://www.incibe.es/en/incibe-cert/notices/aviso/cross-site-scripting-vulnerability-cksource-ckeditor"],"products":["cksource:ckeditor"],"source":"nvd","synced_at":"2026-10-19T21:42:07.670898610+00:00"},"epss":{"cve":"CVE-2023-4771","score":0.00878,"percentile":0.59052,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wh5w-82f3-wrxh","url":"https://osv.dev/vulnerability/GHSA-wh5w-82f3-wrxh","summary":"CKEditor cross-site scripting vulnerability in AJAX sample","modified":"2024-02-07T18:43:08.208352Z","packages":[{"ecosystem":"npm","name":"ckeditor4","purl":"pkg:npm/ckeditor4","ranges":["<4.24.0-lts"],"fixed":["4.24.0-lts"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}