{"cve":"CVE-2023-47248","nvd":{"published":"2023-11-09T09:15:08.223","modified":"2026-06-17T06:32:27.770","status":"Modified","description":"Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).\n\nThis vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.\n\nIt is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.\n\nIf it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See  https://pypi.org/project/pyarrow-hotfix/  for instructions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://github.com/apache/arrow/commit/f14170976372436ec1d03a724d8d3f3925484ecf","https://lists.apache.org/thread/yhy7tdfjf9hrl9vfrtzo8p2cyjq87v7n","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FR34AIPXVTMB3XPRU5ULV5HHWPMRE33X/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MAGWEAJDWO2ACYATUQCPXLSYY5C3L3XU/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MWFYXLVBTBHNKYRXI572RFX7IJDDQGBL/"],"products":["apache:pyarrow"],"source":"nvd","synced_at":"2026-10-19T21:42:07.670898610+00:00"},"epss":{"cve":"CVE-2023-47248","score":0.14528,"percentile":0.96639,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5wvp-7f3h-6wmm","url":"https://osv.dev/vulnerability/GHSA-5wvp-7f3h-6wmm","summary":"PyArrow: Arbitrary code execution when loading a malicious data file","modified":"2026-09-10T03:50:04.164494775Z","packages":[{"ecosystem":"PyPI","name":"pyarrow","purl":"pkg:pypi/pyarrow","ranges":[">=0.14.0 <14.0.1"],"fixed":["14.0.1"]}]},{"id":"PYSEC-2023-238","url":"https://osv.dev/vulnerability/PYSEC-2023-238","summary":"","modified":"2023-11-20T09:26:47.189113Z","packages":[{"ecosystem":"PyPI","name":"pyarrow","purl":"pkg:pypi/pyarrow","ranges":[">=0.14.0 <14.0.1"],"fixed":["14.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}