{"cve":"CVE-2023-46942","nvd":{"published":"2024-01-13T02:15:07.153","modified":"2026-06-17T06:31:51.817","status":"Modified","description":"Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.8, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-287"],"references":["https://advisory.checkmarx.net/advisory/CVE-2023-46942","https://devhub.checkmarx.com/cve-details/CVE-2023-46942/","https://devhub.checkmarx.com/cve-details/Cx00cea2d5-d2c5/","https://advisory.checkmarx.net/advisory/CVE-2023-46942","https://devhub.checkmarx.com/cve-details/CVE-2023-46942/"],"products":["evershop:evershop"],"source":"nvd","synced_at":"2026-10-19T21:43:38.875533635+00:00"},"epss":{"cve":"CVE-2023-46942","score":0.00732,"percentile":0.54341,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-ggpm-9qfx-mhwg","url":"https://osv.dev/vulnerability/GHSA-ggpm-9qfx-mhwg","summary":"EverShop vulnerable to improper authorization in GraphQL endpoints","modified":"2024-07-26T21:37:07Z","packages":[{"ecosystem":"npm","name":"@evershop/evershop","purl":"pkg:npm/%40evershop/evershop","ranges":["<1.0.0-rc.9"],"fixed":["1.0.0-rc.9"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}