{"cve":"CVE-2023-46308","nvd":{"published":"2024-01-03T05:15:11.360","modified":"2026-06-17T06:30:37.893","status":"Modified","description":"In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-1321"],"references":["https://github.com/plotly/plotly.R/issues/2463","https://github.com/plotly/plotly.js/releases/tag/v2.25.2","https://plotly.com/javascript/","https://github.com/plotly/plotly.js/releases/tag/v2.25.2","https://plotly.com/javascript/"],"products":["plotly:plotly.js"],"source":"nvd","synced_at":"2026-10-19T21:43:38.875533635+00:00"},"epss":{"cve":"CVE-2023-46308","score":0.00936,"percentile":0.60833,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wjc4-73q6-gv3m","url":"https://osv.dev/vulnerability/GHSA-wjc4-73q6-gv3m","summary":"plotly.js prototype pollution vulnerability","modified":"2025-12-26T15:36:43.069850Z","packages":[{"ecosystem":"Packagist","name":"plotly/plotly.js","purl":"pkg:composer/plotly/plotly.js","ranges":["<2.25.2"],"fixed":["2.25.2"]},{"ecosystem":"npm","name":"plotly.js","purl":"pkg:npm/plotly.js","ranges":["<2.25.2"],"fixed":["2.25.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}