{"cve":"CVE-2023-46288","nvd":{"published":"2023-10-23T19:15:11.143","modified":"2026-06-17T06:30:35.470","status":"Modified","description":"Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to 2.7.0.\n\nSensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2).\n\nUsers are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","score":4.3},"cwes":["CWE-200"],"references":["http://www.openwall.com/lists/oss-security/2024/04/17/10","https://github.com/apache/airflow/pull/32261","https://lists.apache.org/thread/yw4vzm0c5lqkwm0bxv6qy03yfd1od4nw","http://www.openwall.com/lists/oss-security/2024/04/17/10","https://github.com/apache/airflow/pull/32261"],"products":["apache:airflow"],"source":"nvd","synced_at":"2026-10-19T21:40:11.519948003+00:00"},"epss":{"cve":"CVE-2023-46288","score":0.01839,"percentile":0.78973,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-9qqg-mh7c-chfq","url":"https://osv.dev/vulnerability/GHSA-9qqg-mh7c-chfq","summary":"Apache Airflow vulnerable to Exposure of Sensitive Information","modified":"2025-02-13T19:35:34.251068Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":[">=2.4.0 <2.7.2"],"fixed":["2.7.2"]}]},{"id":"PYSEC-2023-218","url":"https://osv.dev/vulnerability/PYSEC-2023-218","summary":"","modified":"2026-06-10T17:00:23.548480387Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":[">=2.4.0 <2.7.0"],"fixed":["2.7.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}