{"cve":"CVE-2023-45133","nvd":{"published":"2023-10-12T17:15:09.797","modified":"2026-06-17T06:28:17.020","status":"Modified","description":"Babel is a compiler for writingJavaScript. In `@babel/traverse` prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of `babel-traverse`, using Babel to compile code that was specifically crafted by an attacker can lead to arbitrary code execution during compilation, when using plugins that rely on the `path.evaluate()`or `path.evaluateTruthy()` internal Babel methods. Known affected plugins are `@babel/plugin-transform-runtime`; `@babel/preset-env` when using its `useBuiltIns` option; and any \"polyfill provider\" plugin that depends on `@babel/helper-define-polyfill-provider`, such as `babel-plugin-polyfill-corejs3`, `babel-plugin-polyfill-corejs2`, `babel-plugin-polyfill-es-shims`, `babel-plugin-polyfill-regenerator`. No other plugins under the `@babel/` namespace are impacted, but third-party plugins might be. Users that only compile trusted code are not impacted. The vulnerability has been fixed in `@babel/traverse@7.23.2` and `@babel/traverse@8.0.0-alpha.4`. Those who cannot upgrade `@babel/traverse` and are using one of the affected packages mentioned above should upgrade them to their latest version to avoid triggering the vulnerable code path in affected `@babel/traverse` versions: `@babel/plugin-transform-runtime` v7.23.2, `@babel/preset-env` v7.23.2, `@babel/helper-define-polyfill-provider` v0.4.3, `babel-plugin-polyfill-corejs2` v0.4.6, `babel-plugin-polyfill-corejs3` v0.8.5, `babel-plugin-polyfill-es-shims` v0.10.0, `babel-plugin-polyfill-regenerator` v0.5.3.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","score":8.8},"cwes":["CWE-697","CWE-184"],"references":["https://github.com/babel/babel/commit/b13376b346946e3f62fc0848c1d2a23223314c82","https://github.com/babel/babel/pull/16033","https://github.com/babel/babel/releases/tag/v7.23.2","https://github.com/babel/babel/releases/tag/v8.0.0-alpha.4","https://github.com/babel/babel/security/advisories/GHSA-67hx-6x53-jw92"],"products":["babeljs:babel","babeljs:babel-helper-define-polyfill-provider","babeljs:babel-plugin-polyfill-corejs2","babeljs:babel-plugin-polyfill-corejs3","babeljs:babel-plugin-polyfill-es-shims","babeljs:babel-plugin-polyfill-regenerator","babeljs:babel-plugin-transform-runtime","babeljs:babel-preset-env","debian:debian_linux"],"source":"nvd","synced_at":"2026-10-19T21:39:34.467980132+00:00"},"epss":{"cve":"CVE-2023-45133","score":0.00525,"percentile":0.44511,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-67hx-6x53-jw92","url":"https://osv.dev/vulnerability/GHSA-67hx-6x53-jw92","summary":"Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code","modified":"2026-09-10T03:50:03.372029556Z","packages":[{"ecosystem":"npm","name":"@babel/traverse","purl":"pkg:npm/%40babel/traverse","ranges":["<7.23.2"],"fixed":["7.23.2"]},{"ecosystem":"npm","name":"@babel/traverse","purl":"pkg:npm/%40babel/traverse","ranges":[">=8.0.0-alpha.0 <8.0.0-alpha.4"],"fixed":["8.0.0-alpha.4"]},{"ecosystem":"npm","name":"babel-traverse","purl":"pkg:npm/babel-traverse","ranges":["all versions"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}