{"cve":"CVE-2023-41317","nvd":{"published":"2023-09-05T19:15:48.610","modified":"2026-06-17T06:21:44.293","status":"Modified","description":"The Apollo Router is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Affected versions are subject to a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled.  It can be triggered when **all of the following conditions are met**: 1. Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 (\"impacted versions\"); **and** 2. The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) **has a `subscription` type** with root-fields defined; **and** 3. The YAML configuration provided to the Router **has subscriptions enabled** (they are _disabled_ by default), either by setting `enabled: true` _or_ by setting a valid `mode` within the `subscriptions` object (as seen in [subscriptions' documentation](https://www.apollographql.com/docs/router/executing-operations/subscription-support/#router-setup)); **and** 4. An [anonymous](https://spec.graphql.org/draft/#sec-Anonymous-Operation-Definitions) (i.e., un-named) `subscription` operation (e.g., `subscription { ... }`) is received by the Router If **all four** of these criteria are met, the impacted versions will panic and terminate.  There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability. This is fixed in Apollo Router v1.29.1. Users are advised to upgrade. Updating to v1.29.1 should be a clear and simple upgrade path for those running impacted versions.  However, if Subscriptions are **not** necessary for your Graph – but are enabled via configuration — then disabling subscriptions is another option to mitigate the risk.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","score":5.9},"cwes":["CWE-755"],"references":["https://github.com/apollographql/router/commit/b295c103dd86c57c848397d32e8094edfa8502aa","https://github.com/apollographql/router/releases/tag/v1.29.1","https://github.com/apollographql/router/security/advisories/GHSA-w8vq-3hf9-xppx","https://github.com/apollographql/router/commit/b295c103dd86c57c848397d32e8094edfa8502aa","https://github.com/apollographql/router/releases/tag/v1.29.1"],"products":["apollographql:apollo_router"],"source":"nvd","synced_at":"2026-10-19T21:39:24.235896374+00:00"},"epss":{"cve":"CVE-2023-41317","score":0.00805,"percentile":0.56782,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w8vq-3hf9-xppx","url":"https://osv.dev/vulnerability/GHSA-w8vq-3hf9-xppx","summary":"Apollo Router Unnamed \"Subscription\" operation results in Denial-of-Service","modified":"2026-09-10T03:50:03.268373286Z","packages":[{"ecosystem":"crates.io","name":"apollo-router","purl":"pkg:cargo/apollo-router","ranges":[">=1.28.0 <1.29.1"],"fixed":["1.29.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}