{"cve":"CVE-2023-41057","nvd":{"published":"2023-09-04T18:15:09.397","modified":"2026-06-17T06:20:20.680","status":"Modified","description":"hyper-bump-it is a command line tool for updating the version in project files.`hyper-bump-it` reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project. The default behaviour of `hyper-bump-it` is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt. This issue has been fixed in release version 0.5.1. Users are advised to upgrade. Users that are unable to update from vulnerable versions, executing `hyper-bump-it` with the `--interactive` command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains `show_confirm_prompt=true`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","score":5.5},"cwes":["CWE-22"],"references":["https://github.com/plannigan/hyper-bump-it/pull/307","https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448","https://github.com/plannigan/hyper-bump-it/pull/307","https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448"],"products":["plannigan:hyper_bump_it"],"source":"nvd","synced_at":"2026-10-19T21:39:24.235896374+00:00"},"epss":{"cve":"CVE-2023-41057","score":0.00365,"percentile":0.30325,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-xc27-f9q3-4448","url":"https://osv.dev/vulnerability/GHSA-xc27-f9q3-4448","summary":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it","modified":"2026-09-10T03:50:03.462201662Z","packages":[{"ecosystem":"PyPI","name":"hyper-bump-it","purl":"pkg:pypi/hyper-bump-it","ranges":["<0.5.1"],"fixed":["0.5.1"]}]},{"id":"PYSEC-2026-1456","url":"https://osv.dev/vulnerability/PYSEC-2026-1456","summary":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it","modified":"2026-07-07T17:47:44.637781385Z","packages":[{"ecosystem":"PyPI","name":"hyper-bump-it","purl":"pkg:pypi/hyper-bump-it","ranges":["<0.5.1"],"fixed":["0.5.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}