{"cve":"CVE-2023-40581","nvd":{"published":"2023-09-25T19:15:09.960","modified":"2026-06-17T06:18:33.827","status":"Modified","description":"yt-dlp is a youtube-dl fork with additional features and fixes. yt-dlp allows the user to provide shell command lines to be executed at various stages in its download steps through the `--exec` flag. This flag allows output template expansion in its argument, so that metadata values may be used in the shell commands. The metadata fields can be combined with the `%q` conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for `cmd` (the shell used by Python's `subprocess` on Windows) does not properly escape special characters, which can allow for remote code execution if `--exec` is used directly with maliciously crafted remote data. This vulnerability only impacts `yt-dlp` on Windows, and the vulnerability is present regardless of whether `yt-dlp` is run from `cmd` or from `PowerShell`. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2023.09.24 fixes this issue by properly escaping each special character. `\\n` will be replaced by `\\r` as no way of escaping it has been found. It is recommended to upgrade yt-dlp to version 2023.09.24 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: 1. Avoid using any output template expansion in --exec other than {} (filepath). 2. If expansion in --exec is needed, verify the fields you are using do not contain \", | or &. 3. Instead of using --exec, write the info json and load the fields from it instead.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-78"],"references":["https://github.com/yt-dlp/yt-dlp-nightly-builds/releases/tag/2023.09.24.003044","https://github.com/yt-dlp/yt-dlp/commit/de015e930747165dbb8fcd360f8775fd973b7d6e","https://github.com/yt-dlp/yt-dlp/releases/tag/2021.04.11","https://github.com/yt-dlp/yt-dlp/releases/tag/2023.09.24","https://github.com/yt-dlp/yt-dlp/security/advisories/GHSA-42h4-v29r-42qg"],"products":["yt-dlp_project:yt-dlp"],"source":"nvd","synced_at":"2026-10-19T21:39:34.467980132+00:00"},"epss":{"cve":"CVE-2023-40581","score":0.0134,"percentile":0.71315,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-42h4-v29r-42qg","url":"https://osv.dev/vulnerability/GHSA-42h4-v29r-42qg","summary":" yt-dlp on Windows vulnerable to `--exec` command injection when using `%q`","modified":"2026-07-07T17:56:20.918147212Z","packages":[{"ecosystem":"PyPI","name":"yt-dlp","purl":"pkg:pypi/yt-dlp","ranges":[">=2021.04.11 <2023.09.24"],"fixed":["2023.09.24"]}]},{"id":"PYSEC-2026-2064","url":"https://osv.dev/vulnerability/PYSEC-2026-2064","summary":" yt-dlp on Windows vulnerable to `--exec` command injection when using `%q`","modified":"2026-07-07T17:47:49.332019688Z","packages":[{"ecosystem":"PyPI","name":"yt-dlp","purl":"pkg:pypi/yt-dlp","ranges":[">=2021.04.11 <2023.09.24"],"fixed":["2023.09.24"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}