{"cve":"CVE-2023-40340","nvd":{"published":"2023-08-16T15:15:11.620","modified":"2026-06-17T06:17:18.650","status":"Modified","description":"Jenkins NodeJS Plugin 1.6.0 and earlier does not properly mask (i.e., replace with asterisks) credentials specified in the Npm config file in Pipeline build logs.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":[],"references":["http://www.openwall.com/lists/oss-security/2023/08/16/3","https://www.jenkins.io/security/advisory/2023-08-16/#SECURITY-3196","http://www.openwall.com/lists/oss-security/2023/08/16/3","https://www.jenkins.io/security/advisory/2023-08-16/#SECURITY-3196"],"products":["jenkins:nodejs"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-40340","score":0.00633,"percentile":0.50361,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-36fg-whr2-g999","url":"https://osv.dev/vulnerability/GHSA-36fg-whr2-g999","summary":"Jenkins NodeJS Plugin improper credential masking vulnerability","modified":"2024-12-05T05:38:41.919879Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:nodejs","purl":"pkg:maven/org.jenkins-ci.plugins/nodejs","ranges":["<1.6.1"],"fixed":["1.6.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}