{"cve":"CVE-2023-40272","nvd":{"published":"2023-08-17T14:15:10.083","modified":"2026-06-17T06:16:57.870","status":"Modified","description":"Apache Airflow Spark Provider, versions before 4.1.3, is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection giving an opportunity to read files on the Airflow server.\nIt is recommended to upgrade to a version that is not affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-20"],"references":["http://www.openwall.com/lists/oss-security/2023/08/17/1","http://www.openwall.com/lists/oss-security/2023/08/18/1","https://lists.apache.org/thread/t03gktyzyor20rh06okd91jtqmw6k1l7","http://www.openwall.com/lists/oss-security/2023/08/17/1","http://www.openwall.com/lists/oss-security/2023/08/18/1"],"products":["apache:apache-airflow-providers-apache-spark"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-40272","score":0.02144,"percentile":0.8208,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-r2f6-6928-fh8f","url":"https://osv.dev/vulnerability/GHSA-r2f6-6928-fh8f","summary":"Apache Airflow Spark Provider Improper Input Validation vulnerability","modified":"2026-07-07T17:57:18.867451071Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-spark","purl":"pkg:pypi/apache-airflow-providers-apache-spark","ranges":["<4.1.3"],"fixed":["4.1.3"]}]},{"id":"PYSEC-2026-1141","url":"https://osv.dev/vulnerability/PYSEC-2026-1141","summary":"Apache Airflow Spark Provider Improper Input Validation vulnerability","modified":"2026-07-07T17:46:22.285578508Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-spark","purl":"pkg:pypi/apache-airflow-providers-apache-spark","ranges":["<4.1.3"],"fixed":["4.1.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}