{"cve":"CVE-2023-40170","nvd":{"published":"2023-08-28T21:15:07.873","modified":"2026-06-17T06:16:31.720","status":"Modified","description":"jupyter-server is the backend for Jupyter web applications. Improper cross-site credential checks on `/files/` URLs could allow exposure of certain file contents, or accessing files when opening untrusted files via  \"Open image in new tab\". This issue has been addressed in commit `87a49272728` which has been included in release `2.7.2`. Users are advised to upgrade. Users unable to upgrade may use the lower performance `--ContentsManager.files_handler_class=jupyter_server.files.handlers.FilesHandler`, which implements the correct checks.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79","CWE-284","CWE-306"],"references":["https://github.com/jupyter-server/jupyter_server/commit/87a4927272819f0b1cae1afa4c8c86ee2da002fd","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-64x5-55rw-9974","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NRP7DNZYVOIA4ZB3U3ZWKTFZEPYWNGCQ/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XDKQAWQN6SQTOVACZNXYKEHWQXGG4DOF/","https://github.com/jupyter-server/jupyter_server/commit/87a4927272819f0b1cae1afa4c8c86ee2da002fd"],"products":["jupyter:jupyter_server"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-40170","score":0.00623,"percentile":0.49908,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-64x5-55rw-9974","url":"https://osv.dev/vulnerability/GHSA-64x5-55rw-9974","summary":"cross-site inclusion (XSSI) of files in jupyter-server","modified":"2026-09-10T03:49:57.417478394Z","packages":[{"ecosystem":"PyPI","name":"jupyter-server","purl":"pkg:pypi/jupyter-server","ranges":["<2.7.2"],"fixed":["2.7.2"]}]},{"id":"PYSEC-2023-157","url":"https://osv.dev/vulnerability/PYSEC-2023-157","summary":"","modified":"2023-11-08T04:13:19.479699Z","packages":[{"ecosystem":"PyPI","name":"jupyter-server","purl":"pkg:pypi/jupyter-server","ranges":["<2.7.2"],"fixed":["2.7.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}