{"cve":"CVE-2023-39553","nvd":{"published":"2023-08-11T08:15:09.103","modified":"2026-06-17T06:12:35.020","status":"Modified","description":"Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.\n\nApache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server.\nThis issue affects Apache Airflow Drill Provider: before 2.4.3.\nIt is recommended to upgrade to a version that is not affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-20"],"references":["http://www.openwall.com/lists/oss-security/2023/08/11/1","https://github.com/apache/airflow/pull/33074","https://lists.apache.org/thread/ozpl0opmob49rkcz8svo8wkxyw1395sf","http://www.openwall.com/lists/oss-security/2023/08/11/1","https://github.com/apache/airflow/pull/33074"],"products":["apache:apache-airflow-providers-apache-drill"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-39553","score":0.02284,"percentile":0.83162,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-mq4v-6vg4-796c","url":"https://osv.dev/vulnerability/GHSA-mq4v-6vg4-796c","summary":"apache-airflow-providers-apache-drill Improper Input Validation vulnerability","modified":"2026-07-07T17:56:40.304168930Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-drill","purl":"pkg:pypi/apache-airflow-providers-apache-drill","ranges":["<2.4.3"],"fixed":["2.4.3"]}]},{"id":"PYSEC-2023-136","url":"https://osv.dev/vulnerability/PYSEC-2023-136","summary":"","modified":"2026-07-07T17:56:40.304168930Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":["<2.4.3"],"fixed":["2.4.3"]}]},{"id":"PYSEC-2026-1137","url":"https://osv.dev/vulnerability/PYSEC-2026-1137","summary":"apache-airflow-providers-apache-drill Improper Input Validation vulnerability","modified":"2026-07-07T17:56:40.304168930Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-drill","purl":"pkg:pypi/apache-airflow-providers-apache-drill","ranges":["<2.4.3"],"fixed":["2.4.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}