{"cve":"CVE-2023-39020","nvd":{"published":"2023-07-28T15:15:13.287","modified":"2026-06-17T06:11:29.597","status":"Modified","description":"stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component edu.stanford.nlp.io.getBZip2PipedInputStream. This vulnerability is exploited via passing an unchecked argument.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94"],"references":["https://github.com/LetianYuan/My-CVE-Public-References/tree/main/edu_stanford_nlp_stanford-parser","https://github.com/LetianYuan/My-CVE-Public-References/tree/main/edu_stanford_nlp_stanford-parser"],"products":["stanford:stanford_parser"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2023-39020","score":0.0104,"percentile":0.64003,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-353m-jh2m-72v4","url":"https://osv.dev/vulnerability/GHSA-353m-jh2m-72v4","summary":"Code injection in stanford-parser","modified":"2024-09-05T18:47:10.531400Z","packages":[{"ecosystem":"Maven","name":"edu.stanford.nlp:stanford-parser","purl":"pkg:maven/edu.stanford.nlp/stanford-parser","ranges":["<4.5.5"],"fixed":["4.5.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}