{"cve":"CVE-2023-38860","nvd":{"published":"2023-08-15T17:15:11.737","modified":"2026-06-17T06:11:12.740","status":"Modified","description":"An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94"],"references":["https://github.com/hwchase17/langchain/issues/7641","https://github.com/hwchase17/langchain/issues/7641"],"products":["langchain:langchain"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-38860","score":0.01417,"percentile":0.72777,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fj32-q626-pjjc","url":"https://osv.dev/vulnerability/GHSA-fj32-q626-pjjc","summary":"LangChain vulnerable to arbitrary code execution","modified":"2024-09-27T18:01:17.289232Z","packages":[{"ecosystem":"PyPI","name":"langchain","purl":"pkg:pypi/langchain","ranges":["<0.0.247"],"fixed":["0.0.247"]}]},{"id":"PYSEC-2023-145","url":"https://osv.dev/vulnerability/PYSEC-2023-145","summary":"","modified":"2026-06-10T17:01:59.588223152Z","packages":[{"ecosystem":"PyPI","name":"langchain","purl":"pkg:pypi/langchain","ranges":["<0.0.247"],"fixed":["0.0.247"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}