{"cve":"CVE-2023-37941","nvd":{"published":"2023-09-06T14:15:10.483","modified":"2026-06-17T06:08:57.140","status":"Modified","description":"If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.\n\nThe Superset metadata db is an 'internal' component that is typically \nonly accessible directly by the system administrator and the superset \nprocess itself. Gaining access to that database should\n be difficult and require significant privileges.\n\nThis vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","score":6.6},"cwes":["CWE-502"],"references":["http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html","https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h","http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html","https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:39:24.235896374+00:00"},"epss":{"cve":"CVE-2023-37941","score":0.35455,"percentile":0.98451,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fj4x-m62j-wvwg","url":"https://osv.dev/vulnerability/GHSA-fj4x-m62j-wvwg","summary":"Apache Superset Deserialization of Untrusted Data vulnerability","modified":"2026-07-07T17:56:40.946014857Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=1.5.0 <2.1.1"],"fixed":["2.1.1"]}]},{"id":"PYSEC-2026-1175","url":"https://osv.dev/vulnerability/PYSEC-2026-1175","summary":"Apache Superset Deserialization of Untrusted Data vulnerability","modified":"2026-07-07T17:56:40.946014857Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=1.5.0 <2.1.1"],"fixed":["2.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}