{"cve":"CVE-2023-36827","nvd":{"published":"2023-07-05T22:15:10.033","modified":"2026-06-17T06:07:09.740","status":"Modified","description":"Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`.\n\nIf the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-22"],"references":["https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f","https://github.com/ethyca/fides/releases/tag/2.15.1","https://github.com/ethyca/fides/security/advisories/GHSA-r25m-cr6v-p9hq","https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f","https://github.com/ethyca/fides/releases/tag/2.15.1"],"products":["ethyca:fides"],"source":"nvd","synced_at":"2026-10-19T21:38:30.124994567+00:00"},"epss":{"cve":"CVE-2023-36827","score":0.01491,"percentile":0.74126,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r25m-cr6v-p9hq","url":"https://osv.dev/vulnerability/GHSA-r25m-cr6v-p9hq","summary":"ethyca-fides Webserver API Path Traversal vulnerability","modified":"2026-09-10T03:50:02.581542539Z","packages":[{"ecosystem":"PyPI","name":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","ranges":["<2.15.1"],"fixed":["2.15.1"]}]},{"id":"PYSEC-2023-107","url":"https://osv.dev/vulnerability/PYSEC-2023-107","summary":"","modified":"2023-11-08T04:12:59.492694Z","packages":[{"ecosystem":"PyPI","name":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","ranges":["<2.15.1"],"fixed":["2.15.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}