{"cve":"CVE-2023-36258","nvd":{"published":"2023-07-03T21:15:09.797","modified":"2026-06-17T06:05:57.363","status":"Modified","description":"An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be used.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94"],"references":["https://github.com/hwchase17/langchain/issues/5872","https://github.com/hwchase17/langchain/issues/5872"],"products":["langchain:langchain"],"source":"nvd","synced_at":"2026-10-19T21:38:30.124994567+00:00"},"epss":{"cve":"CVE-2023-36258","score":0.01074,"percentile":0.64951,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-2qmj-7962-cjq8","url":"https://osv.dev/vulnerability/GHSA-2qmj-7962-cjq8","summary":"langchain arbitrary code execution vulnerability","modified":"2024-11-22T23:04:53.400191Z","packages":[{"ecosystem":"PyPI","name":"langchain","purl":"pkg:pypi/langchain","ranges":["<0.0.247"],"fixed":["0.0.247"]}]},{"id":"PYSEC-2023-98","url":"https://osv.dev/vulnerability/PYSEC-2023-98","summary":"","modified":"2026-06-10T17:01:58.047656384Z","packages":[{"ecosystem":"PyPI","name":"langchain","purl":"pkg:pypi/langchain","ranges":["<0.0.247"],"fixed":["0.0.247"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}