{"cve":"CVE-2023-35701","nvd":{"published":"2024-05-03T09:15:07.587","modified":"2026-06-17T06:05:02.273","status":"Analyzed","description":"Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive.\n\nThe vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. \n\nThe attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0.\n\nUsers are recommended to upgrade to version 4.0.0, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","score":6.6},"cwes":["CWE-94"],"references":["http://www.openwall.com/lists/oss-security/2024/05/03/3","https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81","http://www.openwall.com/lists/oss-security/2024/05/03/3","https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81"],"products":["apache:hive"],"source":"nvd","synced_at":"2026-10-19T21:49:23.840078609+00:00"},"epss":{"cve":"CVE-2023-35701","score":0.01103,"percentile":0.65754,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-vpw3-3prf-3974","url":"https://osv.dev/vulnerability/GHSA-vpw3-3prf-3974","summary":"Apache Hive Code Injection vulnerability","modified":"2025-02-13T19:11:02.177742Z","packages":[{"ecosystem":"Maven","name":"org.apache.hive:hive-jdbc","purl":"pkg:maven/org.apache.hive/hive-jdbc","ranges":[">=4.0.0-alpha-1 <4.0.0"],"fixed":["4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}