{"cve":"CVE-2023-34610","nvd":{"published":"2023-06-14T14:15:09.917","modified":"2026-06-17T06:03:51.277","status":"Modified","description":"An issue was discovered json-io thru 4.14.0 allows attackers to cause a denial of service or other unspecified impacts via crafted object that uses cyclic dependencies.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-787"],"references":["https://github.com/jdereg/json-io/issues/169","https://github.com/jdereg/json-io/issues/169"],"products":["json-io_project:json-io"],"source":"nvd","synced_at":"2026-10-19T21:38:24.161619714+00:00"},"epss":{"cve":"CVE-2023-34610","score":0.00812,"percentile":0.56986,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-779h-3r69-4f5p","url":"https://osv.dev/vulnerability/GHSA-779h-3r69-4f5p","summary":"json-io vulnerable to stack exhaustion","modified":"2025-01-06T22:24:48.095592Z","packages":[{"ecosystem":"Maven","name":"com.cedarsoftware:json-io","purl":"pkg:maven/com.cedarsoftware/json-io","ranges":["<4.14.1"],"fixed":["4.14.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}