{"cve":"CVE-2023-31007","nvd":{"published":"2023-07-12T10:15:10.013","modified":"2026-06-17T05:56:04.040","status":"Modified","description":"Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.\n\nThis issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.\n\n2.9 Pulsar Broker users should upgrade to at least 2.9.5.\n2.10 Pulsar Broker users should upgrade to at least 2.10.4.\n2.11 Pulsar Broker users should upgrade to at least 2.11.1.\n3.0 Pulsar Broker users are unaffected.\nAny users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","score":6.5},"cwes":["CWE-287"],"references":["https://lists.apache.org/thread/qxn99xxyp0zv6jchjggn3soyo5gvqfxj","https://lists.apache.org/thread/qxn99xxyp0zv6jchjggn3soyo5gvqfxj"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2023-31007","score":0.0102,"percentile":0.63411,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-47r2-phr8-m8cp","url":"https://osv.dev/vulnerability/GHSA-47r2-phr8-m8cp","summary":"Apache Pulsar Broker Improper Authentication vulnerability","modified":"2024-02-16T08:19:02.778431Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.9.0 <2.10.4"],"fixed":["2.10.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.11.0 <2.11.1"],"fixed":["2.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}