{"cve":"CVE-2023-30429","nvd":{"published":"2023-07-12T10:15:09.937","modified":"2026-06-17T05:54:40.883","status":"Modified","description":"Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar.\n\nThis issue affects Apache Pulsar: before 2.10.4, and 2.11.0.\n\nWhen a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role.\n\nThe recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version.\n\n2.10 Pulsar Function Worker users should upgrade to at least 2.10.4.\n2.11 Pulsar Function Worker users should upgrade to at least 2.11.1.\n3.0 Pulsar Function Worker users are unaffected.\nAny users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-863"],"references":["https://lists.apache.org/thread/v0gcvvxswr830314q4b1kybsfmcf3jf8","https://lists.apache.org/thread/v0gcvvxswr830314q4b1kybsfmcf3jf8"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2023-30429","score":0.01035,"percentile":0.63897,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g9cv-v3v4-3h8r","url":"https://osv.dev/vulnerability/GHSA-g9cv-v3v4-3h8r","summary":"Apache Pulsar Incorrect Authorization vulnerability","modified":"2024-02-16T08:08:23.271807Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar","purl":"pkg:maven/org.apache.pulsar/pulsar","ranges":["<2.10.4"],"fixed":["2.10.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar","purl":"pkg:maven/org.apache.pulsar/pulsar","ranges":[">=2.11.0 <2.11.1"],"fixed":["2.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}