{"cve":"CVE-2023-30428","nvd":{"published":"2023-07-12T10:15:09.853","modified":"2026-06-17T05:54:40.713","status":"Modified","description":"Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role.\nThis issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0.\n\nThe vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability.\n\nThere are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants.\n\n2.8 Pulsar Broker users and earlier are unaffected.\n2.9 Pulsar Broker users should upgrade to one of the patched versions.\n2.10 Pulsar Broker users should upgrade to at least 2.10.4.\n2.11 Pulsar Broker users should upgrade to at least 2.11.1.\n3.0 Pulsar Broker users are unaffected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","score":8.1},"cwes":["CWE-863"],"references":["https://lists.apache.org/thread/v39hqtgrmyxr85rmofwvgrktnflbq3q5","https://lists.apache.org/thread/v39hqtgrmyxr85rmofwvgrktnflbq3q5"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2023-30428","score":0.00819,"percentile":0.57211,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-j2r7-3rvw-g7gx","url":"https://osv.dev/vulnerability/GHSA-j2r7-3rvw-g7gx","summary":"Apache Pulsar Broker's Rest Producer vulnerable to Incorrect Authorization","modified":"2024-02-16T08:07:47.154721Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.9.0 <2.10.4"],"fixed":["2.10.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.11.0 <2.11.1"],"fixed":["2.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}