{"cve":"CVE-2023-28669","nvd":{"published":"2023-04-02T21:15:08.807","modified":"2026-06-17T05:48:31.007","status":"Modified","description":"Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2023-03-21/#SECURITY-3061","https://www.jenkins.io/security/advisory/2023-03-21/#SECURITY-3061"],"products":["jenkins:jacoco"],"source":"nvd","synced_at":"2026-10-19T21:37:48.383111019+00:00"},"epss":{"cve":"CVE-2023-28669","score":0.0056,"percentile":0.466,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xj29-gfww-j67g","url":"https://osv.dev/vulnerability/GHSA-xj29-gfww-j67g","summary":"Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting","modified":"2025-02-25T22:08:21.557334Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:jacoco","purl":"pkg:maven/org.jenkins-ci.plugins/jacoco","ranges":["<3.3.2.1"],"fixed":["3.3.2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}