{"cve":"CVE-2023-27905","nvd":{"published":"2023-03-10T21:15:15.790","modified":"2026-06-17T05:46:04.600","status":"Modified","description":"Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","score":9.6},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3063","https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3063"],"products":["jenkins:update-center2"],"source":"nvd","synced_at":"2026-10-19T21:37:41.955480748+00:00"},"epss":{"cve":"CVE-2023-27905","score":0.01541,"percentile":0.74932,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-pqg3-xfx2-fmqp","url":"https://osv.dev/vulnerability/GHSA-pqg3-xfx2-fmqp","summary":"Cross site scripting vulnerability in update-center2 ","modified":"2023-11-08T04:12:08.126721Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci:update-center2","purl":"pkg:maven/org.jenkins-ci/update-center2","ranges":[">=3.13 <3.15"],"fixed":["3.15"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}