{"cve":"CVE-2023-27604","nvd":{"published":"2023-08-28T08:15:14.697","modified":"2026-06-17T05:45:34.243","status":"Modified","description":"Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections.\n\n It is recommended to upgrade to a version that is not affected.\nThis issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-20"],"references":["https://github.com/apache/airflow/pull/33039","https://lists.apache.org/thread/lswlxf11do51ob7f6xyyg8qp3n7wdrgd","https://github.com/apache/airflow/pull/33039","https://lists.apache.org/thread/lswlxf11do51ob7f6xyyg8qp3n7wdrgd"],"products":["apache:airflow_sqoop_provider"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-27604","score":0.01655,"percentile":0.76585,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g3m9-pr5m-4cvp","url":"https://osv.dev/vulnerability/GHSA-g3m9-pr5m-4cvp","summary":"Airflow Sqoop Provider RCE Vulnerability","modified":"2026-07-07T17:56:16.715900966Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","ranges":["<4.0.0"],"fixed":["4.0.0"]}]},{"id":"PYSEC-2026-1142","url":"https://osv.dev/vulnerability/PYSEC-2026-1142","summary":"Airflow Sqoop Provider RCE Vulnerability","modified":"2026-07-07T17:46:22.273772526Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","ranges":["<4.0.0"],"fixed":["4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}