{"cve":"CVE-2023-25805","nvd":{"published":"2023-02-20T16:15:10.827","modified":"2026-06-17T05:42:01.530","status":"Modified","description":"versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-77"],"references":["https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d","https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm","https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d","https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm"],"products":["versionn_project:versionn"],"source":"nvd","synced_at":"2026-10-19T21:37:38.595364862+00:00"},"epss":{"cve":"CVE-2023-25805","score":0.01584,"percentile":0.75571,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fj78-2vc5-f6cm","url":"https://osv.dev/vulnerability/GHSA-fj78-2vc5-f6cm","summary":"Versionn Command Injection Vulnerability","modified":"2023-11-08T04:11:55.685111Z","packages":[{"ecosystem":"npm","name":"versionn","purl":"pkg:npm/versionn","ranges":["<1.1.0"],"fixed":["1.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}