{"cve":"CVE-2023-25662","nvd":{"published":"2023-03-25T00:15:07.260","modified":"2026-06-17T05:41:41.307","status":"Modified","description":"TensorFlow is an open source platform for machine learning. Versions prior to 2.12.0 and 2.11.1 are vulnerable to integer overflow in EditDistance. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-190"],"references":["https://github.com/tensorflow/tensorflow/commit/08b8e18643d6dcde00890733b270ff8d9960c56c","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7jvm-xxmr-v5cw","https://github.com/tensorflow/tensorflow/commit/08b8e18643d6dcde00890733b270ff8d9960c56c","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7jvm-xxmr-v5cw"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:37:48.383111019+00:00"},"epss":{"cve":"CVE-2023-25662","score":0.00394,"percentile":0.33613,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7jvm-xxmr-v5cw","url":"https://osv.dev/vulnerability/GHSA-7jvm-xxmr-v5cw","summary":"TensorFlow vulnerable to integer overflow in EditDistance","modified":"2026-09-10T03:49:52.814678965Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.11.1"],"fixed":["2.11.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.11.1"],"fixed":["2.11.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.11.1"],"fixed":["2.11.1"]}]},{"id":"PYSEC-2026-1958","url":"https://osv.dev/vulnerability/PYSEC-2026-1958","summary":"TensorFlow vulnerable to integer overflow in EditDistance","modified":"2026-07-13T16:43:41.269496161Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.11.1"],"fixed":["2.11.1"]}]},{"id":"PYSEC-2026-3130","url":"https://osv.dev/vulnerability/PYSEC-2026-3130","summary":"TensorFlow vulnerable to integer overflow in EditDistance","modified":"2026-07-13T16:43:41.269496161Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.11.1"],"fixed":["2.11.1"]}]},{"id":"PYSEC-2026-3293","url":"https://osv.dev/vulnerability/PYSEC-2026-3293","summary":"TensorFlow vulnerable to integer overflow in EditDistance","modified":"2026-07-13T16:43:41.269496161Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.11.1"],"fixed":["2.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}