{"cve":"CVE-2023-23627","nvd":{"published":"2023-01-28T00:15:09.577","modified":"2026-06-17T05:37:37.137","status":"Modified","description":"Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/rgrove/sanitize/security/advisories/GHSA-fw3g-2h3j-qmm7","https://github.com/rgrove/sanitize/security/advisories/GHSA-fw3g-2h3j-qmm7"],"products":["sanitize_project:sanitize"],"source":"nvd","synced_at":"2026-10-19T21:37:38.595364862+00:00"},"epss":{"cve":"CVE-2023-23627","score":0.00525,"percentile":0.44519,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-fw3g-2h3j-qmm7","url":"https://osv.dev/vulnerability/GHSA-fw3g-2h3j-qmm7","summary":"Improper neutralization of `noscript` element content may allow XSS in Sanitize","modified":"2023-11-08T04:11:41.856136Z","packages":[{"ecosystem":"RubyGems","name":"sanitize","purl":"pkg:gem/sanitize","ranges":[">=5.0.0 <6.0.1"],"fixed":["6.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}