{"cve":"CVE-2023-23612","nvd":{"published":"2023-01-26T21:18:14.743","modified":"2026-06-17T05:37:34.920","status":"Modified","description":"OpenSearch is an open source distributed and RESTful search engine. OpenSearch uses JWTs to store role claims obtained from the Identity Provider (IdP) when the authentication backend is SAML or OpenID Connect. There is an issue in how those claims are processed from the JWTs where the leading and trailing whitespace is trimmed, allowing users to potentially claim roles they are not assigned to if any role matches the whitespace-stripped version of the roles they are a member of. This issue is only present for authenticated users, and it requires either the existence of roles that match, not considering leading/trailing whitespace, or the ability for users to create said matching roles. In addition, the Identity Provider must allow leading and trailing spaces in role names. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. There are no known workarounds for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-287"],"references":["https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0","https://github.com/opensearch-project/security/security/advisories/GHSA-864v-6qj7-62qj","https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0","https://github.com/opensearch-project/security/security/advisories/GHSA-864v-6qj7-62qj"],"products":["amazon:opensearch"],"source":"nvd","synced_at":"2026-10-19T21:37:34.931465858+00:00"},"epss":{"cve":"CVE-2023-23612","score":0.00796,"percentile":0.56476,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-864v-6qj7-62qj","url":"https://osv.dev/vulnerability/GHSA-864v-6qj7-62qj","summary":"Issue with whitespace in JWT roles in OpenSearch","modified":"2025-01-16T14:43:47.562766Z","packages":[{"ecosystem":"Maven","name":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","ranges":["<1.3.8"],"fixed":["1.3.8"]},{"ecosystem":"Maven","name":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","ranges":[">=2.0.0 <2.5.0"],"fixed":["2.5.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}