{"cve":"CVE-2023-2195","nvd":{"published":"2023-05-16T19:15:08.997","modified":"2026-06-17T05:51:57.883","status":"Modified","description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Code Dx Plugin 3.1.0 and earlier allows attackers to connect to an attacker-specified URL.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","score":3.5},"cwes":["CWE-352"],"references":["https://www.jenkins.io/security/advisory/2023-05-16/#SECURITY-3118","https://www.jenkins.io/security/advisory/2023-05-16/#SECURITY-3118"],"products":["jenkins:code_dx"],"source":"nvd","synced_at":"2026-10-19T21:38:18.424950729+00:00"},"epss":{"cve":"CVE-2023-2195","score":0.00411,"percentile":0.35412,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-gx2j-5vc3-3794","url":"https://osv.dev/vulnerability/GHSA-gx2j-5vc3-3794","summary":"Jenkins Code Dx Plugin cross-site request forgery vulnerability","modified":"2024-02-16T08:05:21.981212Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:codedx","purl":"pkg:maven/org.jenkins-ci.plugins/codedx","ranges":["<4.0.0"],"fixed":["4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}