{"cve":"CVE-2022-47085","nvd":{"published":"2023-07-18T14:15:12.263","modified":"2026-06-17T05:12:58.607","status":"Modified","description":"An issue was discovered in ostree before 2022.7 allows attackers to cause a denial of service or other unspecified impacts via the print_panic function in repo_checkout_filter.rs.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":[],"references":["https://doc.rust-lang.org/std/macro.eprintln.html","https://github.com/ostreedev/ostree/issues/2775","https://doc.rust-lang.org/std/macro.eprintln.html","https://github.com/ostreedev/ostree/issues/2775"],"products":["ostree_project:ostree"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2022-47085","score":0.00866,"percentile":0.58713,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-x96g-95fq-4xv4","url":"https://osv.dev/vulnerability/GHSA-x96g-95fq-4xv4","summary":"libostree vulnerable to denial of service attack","modified":"2023-12-20T23:41:34.819507Z","packages":[{"ecosystem":"crates.io","name":"ostree","purl":"pkg:cargo/ostree","ranges":["<0.17.1"],"fixed":["0.17.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}