{"cve":"CVE-2022-46792","nvd":{"published":"2022-12-08T06:15:08.940","modified":"2026-06-17T05:12:23.323","status":"Modified","description":"Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-863"],"references":["https://github.com/hasura/graphql-engine/security/advisories/GHSA-g7mj-g7f4-hgrg","https://groups.google.com/g/hasura-security-announce/c/kzK-uPAKGUU","https://hasura.io/blog/critical-vulnerability-in-hasuras-graphql-engine-v2-10-0/","https://github.com/hasura/graphql-engine/security/advisories/GHSA-g7mj-g7f4-hgrg","https://groups.google.com/g/hasura-security-announce/c/kzK-uPAKGUU"],"products":["hasura:graphql_engine"],"source":"nvd","synced_at":"2026-10-19T21:37:28.463369388+00:00"},"epss":{"cve":"CVE-2022-46792","score":0.00879,"percentile":0.59099,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}