{"cve":"CVE-2022-45855","nvd":{"published":"2023-07-12T10:15:09.547","modified":"2026-06-17T05:10:52.290","status":"Modified","description":"SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-917"],"references":["https://lists.apache.org/thread/302c4hwfjy9lx63jrbhcdx948pxc54l1","https://lists.apache.org/thread/302c4hwfjy9lx63jrbhcdx948pxc54l1"],"products":["apache:ambari"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2022-45855","score":0.01212,"percentile":0.68505,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p7w2-784m-qpq9","url":"https://osv.dev/vulnerability/GHSA-p7w2-784m-qpq9","summary":"Apache Ambari Expression Language Injection vulnerability","modified":"2023-11-08T04:10:53.882045Z","packages":[{"ecosystem":"Maven","name":"org.apache.ambari:ambari","purl":"pkg:maven/org.apache.ambari/ambari","ranges":[">=2.7.0 <2.7.7"],"fixed":["2.7.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}