{"cve":"CVE-2022-45598","nvd":{"published":"2023-01-31T16:15:09.053","modified":"2026-06-17T05:10:26.443","status":"Modified","description":"Cross Site Scripting vulnerability in Joplin Desktop App before v2.9.17 allows attacker to execute arbitrary code via improper santization.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/laurent22/joplin/commit/a2de167b95debad83a0f0c7925a88c0198db812e","https://github.com/laurent22/joplin/releases/tag/v2.9.17","https://github.com/laurent22/joplin/commit/a2de167b95debad83a0f0c7925a88c0198db812e","https://github.com/laurent22/joplin/releases/tag/v2.9.17"],"products":["joplin_project:joplin"],"source":"nvd","synced_at":"2026-10-19T21:37:38.595364862+00:00"},"epss":{"cve":"CVE-2022-45598","score":0.00452,"percentile":0.39267,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-h6c2-879r-jffh","url":"https://osv.dev/vulnerability/GHSA-h6c2-879r-jffh","summary":"Joplin Desktop App vulnerable to Cross-site Scripting","modified":"2023-11-08T04:10:53.211506Z","packages":[{"ecosystem":"npm","name":"joplin","purl":"pkg:npm/joplin","ranges":["<2.9.17"],"fixed":["2.9.17"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}