{"cve":"CVE-2022-44621","nvd":{"published":"2022-12-30T11:15:10.467","modified":"2026-06-17T05:08:37.137","status":"Modified","description":"Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-77"],"references":["https://lists.apache.org/thread/7ctchj24dofgsj9g1rg1245cms9myb34","https://lists.apache.org/thread/7ctchj24dofgsj9g1rg1245cms9myb34"],"products":["apache:kylin"],"source":"nvd","synced_at":"2026-10-19T21:37:31.370122805+00:00"},"epss":{"cve":"CVE-2022-44621","score":0.03052,"percentile":0.87571,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w9rv-xmf7-x3gh","url":"https://osv.dev/vulnerability/GHSA-w9rv-xmf7-x3gh","summary":"Apache Kylin vulnerable to Command injection by Diagnosis Controller","modified":"2025-04-11T23:41:17.098877Z","packages":[{"ecosystem":"Maven","name":"org.apache.kylin:kylin-server-base","purl":"pkg:maven/org.apache.kylin/kylin-server-base","ranges":[">=2.0.0 <4.0.3"],"fixed":["4.0.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}