{"cve":"CVE-2022-41227","nvd":{"published":"2022-09-21T16:15:10.037","modified":"2026-06-17T05:02:49.770","status":"Modified","description":"A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2737","https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2737"],"products":["jenkins:ns-nd_integration_performance_publisher"],"source":"nvd","synced_at":"2026-10-19T21:36:05.460296998+00:00"},"epss":{"cve":"CVE-2022-41227","score":0.00543,"percentile":0.45621,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-jjch-7g85-4m72","url":"https://osv.dev/vulnerability/GHSA-jjch-7g85-4m72","summary":"Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery","modified":"2023-11-08T04:10:27.522133Z","packages":[{"ecosystem":"Maven","name":"io.jenkins.plugins:cavisson-ns-nd-integration","purl":"pkg:maven/io.jenkins.plugins/cavisson-ns-nd-integration","ranges":["<4.8.0.130"],"fixed":["4.8.0.130"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}