{"cve":"CVE-2022-39379","nvd":{"published":"2022-11-02T13:15:13.583","modified":"2026-06-17T04:58:14.957","status":"Modified","description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://github.com/fluent/fluentd/commit/48e5b85dab1b6d4c273090d538fc11b3f2fd8135","https://github.com/fluent/fluentd/security/advisories/GHSA-fppq-mj76-fpj2","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO/","https://github.com/fluent/fluentd/commit/48e5b85dab1b6d4c273090d538fc11b3f2fd8135","https://github.com/fluent/fluentd/security/advisories/GHSA-fppq-mj76-fpj2"],"products":["fedoraproject:fedora","fluentd:fluentd"],"source":"nvd","synced_at":"2026-10-19T21:37:08.729216836+00:00"},"epss":{"cve":"CVE-2022-39379","score":0.44983,"percentile":0.98781,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fppq-mj76-fpj2","url":"https://osv.dev/vulnerability/GHSA-fppq-mj76-fpj2","summary":"fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)","modified":"2024-02-21T05:28:11.809766Z","packages":[{"ecosystem":"RubyGems","name":"fluentd","purl":"pkg:gem/fluentd","ranges":[">=1.13.2 <1.15.3"],"fixed":["1.15.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}