{"cve":"CVE-2022-39263","nvd":{"published":"2022-09-28T21:15:14.590","modified":"2026-06-17T04:58:01.683","status":"Modified","description":"`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","score":8.1},"cwes":["CWE-287"],"references":["https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9","https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9","https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9","https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9"],"products":["nextauth.js:next-auth"],"source":"nvd","synced_at":"2026-10-19T21:36:05.460296998+00:00"},"epss":{"cve":"CVE-2022-39263","score":0.00721,"percentile":0.53985,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4rxr-27mm-mxq9","url":"https://osv.dev/vulnerability/GHSA-4rxr-27mm-mxq9","summary":"Upstash Adapter missing token verification","modified":"2023-11-08T04:10:17.066346Z","packages":[{"ecosystem":"npm","name":"@next-auth/upstash-redis-adapter","purl":"pkg:npm/%40next-auth/upstash-redis-adapter","ranges":["<3.0.2"],"fixed":["3.0.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}