{"cve":"CVE-2022-35980","nvd":{"published":"2022-08-12T18:15:13.510","modified":"2026-06-17T04:52:38.750","status":"Modified","description":"OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. Versions 2.0.0.0 and 2.1.0.0 of the security plugin are affected by an information disclosure vulnerability. Requests to an OpenSearch cluster configured with advanced access control features document level security (DLS), field level security (FLS), and/or field masking will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. OpenSearch 2.2.0, which is compatible with OpenSearch Security 2.2.0.0, contains the fix for this issue. There is no recommended work around.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-612"],"references":["https://github.com/opensearch-project/security/commit/7eaaafec2939d7db23a02ffca9cc68e0343de246","https://github.com/opensearch-project/security/pull/1999","https://github.com/opensearch-project/security/security/advisories/GHSA-f4qr-f4xx-hjxw","https://github.com/opensearch-project/security/commit/7eaaafec2939d7db23a02ffca9cc68e0343de246","https://github.com/opensearch-project/security/pull/1999"],"products":["amazon:opensearch"],"source":"nvd","synced_at":"2026-10-19T21:34:18.502168378+00:00"},"epss":{"cve":"CVE-2022-35980","score":0.01231,"percentile":0.6896,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-f4qr-f4xx-hjxw","url":"https://osv.dev/vulnerability/GHSA-f4qr-f4xx-hjxw","summary":"OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information","modified":"2023-11-08T04:09:55.363295Z","packages":[{"ecosystem":"Maven","name":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","ranges":[">=2.0.0.0 <2.2.0.0"],"fixed":["2.2.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}